summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2019-09-04 23:34:54 +0200
committerpeterbell10 <peterbell10@live.co.uk>2019-09-04 23:34:54 +0200
commitf021e2fe22fab34a48bedefe3f19533fa60754ff (patch)
tree182543d16d4ab0c1206dcdbd9e56e1ed2879c0b0 /CMakeLists.txt
parentAdded a basic PalettedBlockArea implementation (#4377) (diff)
downloadcuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar.gz
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar.bz2
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar.lz
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar.xz
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.tar.zst
cuberite-f021e2fe22fab34a48bedefe3f19533fa60754ff.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 084c4f417..237257590 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -192,11 +192,12 @@ set(SQLITECPP_INTERNAL_SQLITE OFF CACHE BOOL "Add the internal SQLite3 source to
set(SQLITE_ENABLE_COLUMN_METADATA OFF CACHE BOOL "" FORCE)
# Set options for LibEvent, disable all their tests and benchmarks:
-set(EVENT__DISABLE_OPENSSL YES CACHE BOOL "Disable OpenSSL in LibEvent" FORCE)
-set(EVENT__DISABLE_BENCHMARK YES CACHE BOOL "Disable LibEvent benchmarks" FORCE)
-set(EVENT__DISABLE_TESTS YES CACHE BOOL "Disable LibEvent tests" FORCE)
-set(EVENT__DISABLE_REGRESS YES CACHE BOOL "Disable LibEvent regression tests" FORCE)
-set(EVENT__DISABLE_SAMPLES YES CACHE BOOL "Disable LibEvent samples" FORCE)
+set(EVENT__DISABLE_OPENSSL YES CACHE BOOL "Disable OpenSSL in LibEvent" FORCE)
+set(EVENT__DISABLE_BENCHMARK YES CACHE BOOL "Disable LibEvent benchmarks" FORCE)
+set(EVENT__DISABLE_TESTS YES CACHE BOOL "Disable LibEvent tests" FORCE)
+set(EVENT__DISABLE_REGRESS YES CACHE BOOL "Disable LibEvent regression tests" FORCE)
+set(EVENT__DISABLE_SAMPLES YES CACHE BOOL "Disable LibEvent samples" FORCE)
+set(EVENT__LIBRARY_TYPE "STATIC" CACHE STRING "Use static LibEvent libraries" FORCE)
# Set options for JsonCPP, disabling all of their tests
# Additionally, their library is output to a strange location; make sure the linker knows where to find it
@@ -301,8 +302,8 @@ endif()
# Put projects into solution folders in MSVC:
if (MSVC)
set_target_properties(
- event_core
- event_extra
+ event_core_static
+ event_extra_static
expat
fmt
jsoncpp_lib_static