summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@hotmail.co.uk>2015-05-09 02:22:33 +0200
committerTiger Wang <ziwei.tiger@hotmail.co.uk>2015-07-10 00:10:51 +0200
commitccfe04a0a2b64c2bdfd10c4a0aadf61847001eae (patch)
treed7b0e9aab9f4c81c58121c5b06411b25a2efba00 /CMakeLists.txt
parentUpdated luaexpat (diff)
downloadcuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar.gz
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar.bz2
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar.lz
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar.xz
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.tar.zst
cuberite-ccfe04a0a2b64c2bdfd10c4a0aadf61847001eae.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db397a2d2..6c625006d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -147,6 +147,11 @@ set(EVENT__DISABLE_TESTS YES CACHE BOOL "Disable LibEvent tests"
set(EVENT__DISABLE_REGRESS YES CACHE BOOL "Disable LibEvent regression tests" FORCE)
set(EVENT__DISABLE_SAMPLES YES CACHE BOOL "Disable LibEvent samples" FORCE)
+# Set options for JsonCPP, disabling all of their tests
+set(JSONCPP_WITH_TESTS OFF CACHE BOOL "Compile and (for jsoncpp_check) run JsonCpp test executables")
+set(JSONCPP_WITH_POST_BUILD_UNITTEST OFF CACHE BOOL "Automatically run unit-tests as a post build step")
+set(JSONCPP_WITH_PKGCONFIG_SUPPORT OFF CACHE BOOL "Generate and install .pc files")
+
# Check that the libraries are present:
if (NOT EXISTS ${CMAKE_SOURCE_DIR}/lib/SQLiteCpp/CMakeLists.txt)
message(FATAL_ERROR "SQLiteCpp is missing in folder lib/SQLiteCpp. Have you initialized the submodules / downloaded the extra libraries?")