summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@outlook.com>2020-09-17 15:51:42 +0200
committerGitHub <noreply@github.com>2020-09-17 15:51:42 +0200
commitc3d2956ba588a4559fabc36a0c1fc7dd28279314 (patch)
treeb8210f994441a20ab08499df442e15fb9afaaf30 /CMakeLists.txt
parentAdd some const qualifiers to functions (#4874) (diff)
downloadcuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar.gz
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar.bz2
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar.lz
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar.xz
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.tar.zst
cuberite-c3d2956ba588a4559fabc36a0c1fc7dd28279314.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6fd2f2b22..7bd7c1941 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,6 +92,9 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
# File failed to follow NHS guidelines on handwashing and has not maintained good hygiene
set_source_files_properties("${CMAKE_SOURCE_DIR}/src/IniFile.cpp" PROPERTIES COMPILE_OPTIONS -Wno-header-hygiene)
+
+ # Enforce BlockHandler handling all blocks in switch statements
+ set_source_files_properties("${CMAKE_SOURCE_DIR}/src/Blocks/BlockHandler.cpp" PROPERTIES COMPILE_OPTIONS -Werror=switch)
endif()
if(${BUILD_TOOLS})