summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-01-07 17:07:01 +0100
committerMattes D <github@xoft.cz>2014-01-07 17:07:01 +0100
commit748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c (patch)
tree9601c178ed1d3f1ac0e98f11cada46bcb5055ebe /CMakeLists.txt
parentUpdate CONTRIBUTING.md (diff)
parentFixed FreeBSD compilition (diff)
downloadcuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar.gz
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar.bz2
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar.lz
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar.xz
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.tar.zst
cuberite-748fd86b83adc5c4f6acd5fd2ffb3d62b79e4a3c.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 451854074..135826abc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,6 +97,17 @@ if (WIN32)
add_definitions(-DLUA_BUILD_AS_DLL)
endif()
+#On Unix we use two dynamic loading libraries dl and ltdl.
+#Preference is for dl on unknown systems as it is specified in POSIX
+#the dynamic loader is used by lua and sqllite.
+if (UNIX)
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ set(DYNAMIC_LOADER ltdl)
+ else()
+ set(DYNAMIC_LOADER dl)
+ endif()
+endif()
+
# The Expat library is linked in statically, make the source files aware of that:
add_definitions(-DXML_STATIC)