summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTycho Bickerstaff <work.tycho@gmail.com>2014-01-02 18:11:40 +0100
committerTycho Bickerstaff <work.tycho@gmail.com>2014-01-02 18:11:40 +0100
commit7076f8e73a1e4fed8388d0604756c4c91cafb416 (patch)
tree9ea25f637e6f326ad673b3f4806726da19762120 /CMakeLists.txt
parentMerge pull request #484 from worktycho/cmake-fixes (diff)
downloadcuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar.gz
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar.bz2
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar.lz
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar.xz
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.tar.zst
cuberite-7076f8e73a1e4fed8388d0604756c4c91cafb416.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 67f70142b..451854074 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,11 +112,15 @@ add_subdirectory(lib/expat/)
add_subdirectory(lib/luaexpat/)
add_subdirectory(lib/md5/)
-# Re-add the maximum warning level:
+# Remove disabling the maximum warning level:
+# clang does not like a command line that reads -Wall -Wextra -w -Wall -Wextra and does not output any warnings
# We do not do that for MSVC since MSVC produces an awful lot of warnings for its own STL headers;
# the important warnings will be turned on using #pragma in Globals.h
if (NOT MSVC)
- add_flags("-Wall -Wextra")
+ string(REPLACE "-w" "" CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
+ string(REPLACE "-w" "" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
+ string(REPLACE "-w" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
+ string(REPLACE "-w" "" CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG}")
endif()
add_subdirectory (src)