summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authortycho <tycho@hanoverdesktop>2013-12-20 00:42:47 +0100
committertycho <tycho@hanoverdesktop>2013-12-20 00:42:47 +0100
commit622777f545f99a65e0f07094326e9b209f17baf2 (patch)
treea4940c90feaf696df862a171a843ac9937cefee2 /CMakeLists.txt
parentfixed multiprocessing on windows and removed redundend compile of headers (diff)
downloadcuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar.gz
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar.bz2
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar.lz
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar.xz
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.tar.zst
cuberite-622777f545f99a65e0f07094326e9b209f17baf2.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 515cb1570..4201602f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,9 @@ if (UNIX)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -w")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -w")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /w")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /w")
+ #remove /W3 from command line -- cannot just cancel it later with /w like in unix because of D9025
+ string(REPLACE "/W3" "" CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
+ string(REPLACE "/W3" "" CMAKE_C_FLAGS "${CMAKE_C_FLAGS}")
endif()
set(CMAKE_BUILD_TYPE_BAK ${CMAKE_BUILD_TYPE})
set(CMAKE_BUILD_TYPE "Release")