summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTiger Wang <ziwei.tiger@hotmail.co.uk>2014-01-24 14:53:19 +0100
committerTiger Wang <ziwei.tiger@hotmail.co.uk>2014-01-24 14:53:19 +0100
commit17c949ea6900f01a31d951cc4228139f9a6334df (patch)
tree5e5007b7b6040c8052e66c8ef1a0d39f55f1c5fe /CMakeLists.txt
parentMerge branch 'master' into ChangeToPolarSSL. (diff)
downloadcuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar.gz
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar.bz2
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar.lz
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar.xz
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.tar.zst
cuberite-17c949ea6900f01a31d951cc4228139f9a6334df.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a10db7d49..181b286e9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,3 @@
-
cmake_minimum_required (VERSION 2.6)
# Without this, the MSVC variable isn't defined for MSVC builds ( http://www.cmake.org/pipermail/cmake/2011-November/047130.html )
@@ -92,12 +91,6 @@ else()
endif()
-# Under clang, we need to disable ASM support in CryptoPP:
-if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_definitions(-DCRYPTOPP_DISABLE_ASM)
-endif()
-
-
# Under Windows, we need Lua as DLL; on *nix we need it linked statically:
if (WIN32)
add_definitions(-DLUA_BUILD_AS_DLL)