summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorworktycho <work.tycho@gmail.com>2014-03-07 21:16:16 +0100
committerworktycho <work.tycho@gmail.com>2014-03-07 21:16:16 +0100
commit0eea9eb99841ba379475a277af860d22ac156071 (patch)
treefed0b80449b98ae96d2e2671f52f89acc62200e8 /CMakeLists.txt
parentFixed wrong path in debug mode (diff)
downloadcuberite-0eea9eb99841ba379475a277af860d22ac156071.tar
cuberite-0eea9eb99841ba379475a277af860d22ac156071.tar.gz
cuberite-0eea9eb99841ba379475a277af860d22ac156071.tar.bz2
cuberite-0eea9eb99841ba379475a277af860d22ac156071.tar.lz
cuberite-0eea9eb99841ba379475a277af860d22ac156071.tar.xz
cuberite-0eea9eb99841ba379475a277af860d22ac156071.tar.zst
cuberite-0eea9eb99841ba379475a277af860d22ac156071.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05b6d879b..e7e8daf7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,15 @@ cmake_minimum_required (VERSION 2.6)
# Without this, the MSVC variable isn't defined for MSVC builds ( http://www.cmake.org/pipermail/cmake/2011-November/047130.html )
enable_language(CXX C)
+if(DEFINED ENV{MCSERVER_BUILD_TYPE})
+ message("Setting build type to $ENV{MCSERVER_BUILD_TYPE}")
+ set(CMAKE_BUILD_TYPE $ENV{MCSERVER_BUILD_TYPE})
+endif()
+
+if(DEFINED ENV{MCSERVER_FORCE32})
+ set(FORCE32 $ENV{MCSERVER_FORCE32})
+endif()
+
# This has to be done before any flags have been set up.
if(${BUILD_TOOLS})
add_subdirectory(Tools/MCADefrag/)