summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormadmaxoft <github@xoft.cz>2014-07-28 19:59:53 +0200
committermadmaxoft <github@xoft.cz>2014-07-28 19:59:53 +0200
commit036a8ff98e890071089e9938cb87c5c4323152f0 (patch)
tree7b9f320fd2ddc47383ad5a7c94c7ef6a7e9cf4d4 /CMakeLists.txt
parentDebuggers: Added an example for cClientHandle:GetUUIDsFromPlayerNames(). (diff)
downloadcuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar.gz
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar.bz2
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar.lz
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar.xz
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.tar.zst
cuberite-036a8ff98e890071089e9938cb87c5c4323152f0.zip
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a6400c1b4..478b79047 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,14 @@ endif()
project (MCServer)
+# Set options for SQLiteCpp, disable all their tests and lints:
+set(SQLITECPP_RUN_CPPLINT OFF CACHE BOOL "Run cpplint.py tool for Google C++ StyleGuide." FORCE)
+set(SQLITECPP_RUN_CPPCHECK OFF CACHE BOOL "Run cppcheck C++ static analysis tool." FORCE)
+set(SQLITECPP_RUN_DOXYGEN OFF CACHE BOOL "Run Doxygen C++ documentation tool." FORCE)
+set(SQLITECPP_BUILD_EXAMPLES OFF CACHE BOOL "Build examples." FORCE)
+set(SQLITECPP_BUILD_TESTS OFF CACHE BOOL "Build and run tests." FORCE)
+set(SQLITECPP_INTERNAL_SQLITE OFF CACHE BOOL "Add the internal SQLite3 source to the project." FORCE)
+
# Include all the libraries:
add_subdirectory(lib/inifile/)
add_subdirectory(lib/jsoncpp/)
@@ -60,6 +68,7 @@ add_subdirectory(lib/zlib/)
add_subdirectory(lib/lua/)
add_subdirectory(lib/tolua++/)
add_subdirectory(lib/sqlite/)
+add_subdirectory(lib/SQLiteCpp/)
add_subdirectory(lib/expat/)
add_subdirectory(lib/luaexpat/)