summaryrefslogtreecommitdiffstats
path: root/rust/wolfree_sed_in_place/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/wolfree_sed_in_place/Cargo.toml')
-rw-r--r--rust/wolfree_sed_in_place/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/rust/wolfree_sed_in_place/Cargo.toml b/rust/wolfree_sed_in_place/Cargo.toml
new file mode 100644
index 0000000..ab2b32f
--- /dev/null
+++ b/rust/wolfree_sed_in_place/Cargo.toml
@@ -0,0 +1,22 @@
+# SPDX-License-Identifier: AGPL-3.0-or-later
+# This file is part of Wolfree.
+# This program is free software: you can redistribute it and/or modify it under the terms of the GNU Affero General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.
+
+[package]
+name = "wolfree_sed_in_place"
+version = "23.7.31"
+edition = "2021"
+
+authors = ["See the commit history of the Git repositories: <https://try.gitea.io/wolfree>"]
+description = "This Rust program performs in-place search and replaces operations on all files within specified directories. It uses regular expressions to find occurrences of a given pattern in each file's contents and replaces them with the replacement text."
+license = "AGPL-3.0-or-later"
+repository = "https://try.gitea.io/wolfree"
+readme = "README.md"
+keywords = ["rust", "search", "replace", "regular expressions", "regex", "file", "in-place"]
+categories = ["command-line-utilities", "development-tools::build-utils", "web-programming", "template-engine"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+regex = "1"
+walkdir = "2"