summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/input_common/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 9f4422269..cfe5caaa3 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -10,8 +10,18 @@ set(HEADERS
main.h
)
+if(SDL2_FOUND)
+ set(SRCS ${SRCS} sdl/sdl.cpp)
+ set(HEADERS ${HEADERS} sdl/sdl.h)
+ include_directories(${SDL2_INCLUDE_DIR})
+endif()
+
create_directory_groups(${SRCS} ${HEADERS})
add_library(input_common STATIC ${SRCS} ${HEADERS})
target_link_libraries(input_common common core)
+if(SDL2_FOUND)
+ target_link_libraries(input_common ${SDL2_LIBRARY})
+ set_property(TARGET input_common APPEND PROPERTY COMPILE_DEFINITIONS HAVE_SDL2)
+endif()