summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/input_common/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
new file mode 100644
index 000000000..cfe5caaa3
--- /dev/null
+++ b/src/input_common/CMakeLists.txt
@@ -0,0 +1,27 @@
+set(SRCS
+ analog_from_button.cpp
+ keyboard.cpp
+ main.cpp
+ )
+
+set(HEADERS
+ analog_from_button.h
+ keyboard.h
+ main.h
+ )
+
+if(SDL2_FOUND)
+ set(SRCS ${SRCS} sdl/sdl.cpp)
+ set(HEADERS ${HEADERS} sdl/sdl.h)
+ include_directories(${SDL2_INCLUDE_DIR})
+endif()
+
+create_directory_groups(${SRCS} ${HEADERS})
+
+add_library(input_common STATIC ${SRCS} ${HEADERS})
+target_link_libraries(input_common common core)
+
+if(SDL2_FOUND)
+ target_link_libraries(input_common ${SDL2_LIBRARY})
+ set_property(TARGET input_common APPEND PROPERTY COMPILE_DEFINITIONS HAVE_SDL2)
+endif()