summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core/CMakeLists.txt')
-rw-r--r--src/core/CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 4fddaafd1..4755ec822 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -236,6 +236,24 @@ add_library(core STATIC
hle/service/hid/irs.h
hle/service/hid/xcd.cpp
hle/service/hid/xcd.h
+ hle/service/hid/controllers/controller_base.cpp
+ hle/service/hid/controllers/controller_base.h
+ hle/service/hid/controllers/debug_pad.cpp
+ hle/service/hid/controllers/debug_pad.h
+ hle/service/hid/controllers/gesture.cpp
+ hle/service/hid/controllers/gesture.h
+ hle/service/hid/controllers/keyboard.cpp
+ hle/service/hid/controllers/keyboard.h
+ hle/service/hid/controllers/mouse.cpp
+ hle/service/hid/controllers/mouse.h
+ hle/service/hid/controllers/npad.cpp
+ hle/service/hid/controllers/npad.h
+ hle/service/hid/controllers/stubbed.cpp
+ hle/service/hid/controllers/stubbed.h
+ hle/service/hid/controllers/touchscreen.cpp
+ hle/service/hid/controllers/touchscreen.h
+ hle/service/hid/controllers/xpad.cpp
+ hle/service/hid/controllers/xpad.h
hle/service/lbl/lbl.cpp
hle/service/lbl/lbl.h
hle/service/ldn/ldn.cpp
@@ -400,8 +418,8 @@ create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)
target_link_libraries(core PUBLIC Boost::boost PRIVATE fmt lz4_static mbedtls opus unicorn open_source_archives)
if (ENABLE_WEB_SERVICE)
- add_definitions(-DENABLE_WEB_SERVICE)
- target_link_libraries(core PUBLIC json-headers web_service)
+ target_compile_definitions(core PRIVATE -DENABLE_WEB_SERVICE)
+ target_link_libraries(core PRIVATE web_service)
endif()
if (ARCHITECTURE_x86_64)