summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 39d038493..54de1dc94 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,3 +1,6 @@
+# SPDX-FileCopyrightText: 2018 yuzu Emulator Project
+# SPDX-License-Identifier: GPL-2.0-or-later
+
# Enable modules to include each other's files
include_directories(.)
@@ -36,7 +39,6 @@ if (MSVC)
# /GT - Supports fiber safety for data allocated using static thread-local storage
add_compile_options(
/MP
- /Zi
/Zm200
/Zo
/permissive-
@@ -79,6 +81,13 @@ if (MSVC)
/we5245 # 'function': unreferenced function with internal linkage has been removed
)
+ if (USE_CCACHE)
+ # when caching, we need to use /Z7 to downgrade debug info to use an older but more cachable format
+ add_compile_options(/Z7)
+ else()
+ add_compile_options(/Zi)
+ endif()
+
if (ARCHITECTURE_x86_64)
add_compile_options(/QIntel-jcc-erratum)
endif()
@@ -150,8 +159,10 @@ add_subdirectory(common)
add_subdirectory(core)
add_subdirectory(audio_core)
add_subdirectory(video_core)
+add_subdirectory(network)
add_subdirectory(input_common)
add_subdirectory(shader_recompiler)
+add_subdirectory(dedicated_room)
if (YUZU_TESTS)
add_subdirectory(tests)