summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 11 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c9b7f86a..25631b32e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,9 @@ if (NOT MSVC)
if (MINGW)
add_definitions(-DMINGW_HAS_SECURE_API)
+ # Microprofile causes crashes when launching titles on MinGW
+ add_definitions(-DMICROPROFILE_ENABLED=0)
+
if (MINGW_STATIC_BUILD)
add_definitions(-DQT_STATICPLUGIN)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -static")
@@ -182,15 +185,15 @@ IF (APPLE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -stdlib=libc++")
-ELSEIF(MINGW)
- # PSAPI is the Process Status API
- set(PLATFORM_LIBRARIES winmm ws2_32 psapi imm32 version)
-
- # WSAPoll functionality doesn't exist before WinNT 6.x (Vista and up)
- add_definitions(-D_WIN32_WINNT=0x0600)
-ELSEIF(WIN32)
+ELSEIF (WIN32)
+ # WSAPoll and SHGetKnownFolderPath (AppData/Roaming) didn't exist before WinNT 6.x (Vista)
+ add_definitions(-D_WIN32_WINNT=0x0600 -DWINVER=0x0600)
set(PLATFORM_LIBRARIES winmm ws2_32)
-ELSEIF(CMAKE_SYSTEM_NAME MATCHES "^(Linux|kFreeBSD|GNU|SunOS)$")
+ IF (MINGW)
+ # PSAPI is the Process Status API
+ set(PLATFORM_LIBRARIES ${PLATFORM_LIBRARIES} psapi imm32 version)
+ ENDIF (MINGW)
+ELSEIF (CMAKE_SYSTEM_NAME MATCHES "^(Linux|kFreeBSD|GNU|SunOS)$")
set(PLATFORM_LIBRARIES rt)
ENDIF (APPLE)