summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorRodrigo Locatti <reinuseslisp@airmail.cc>2020-12-25 06:52:29 +0100
committerGitHub <noreply@github.com>2020-12-25 06:52:29 +0100
commit453560fb3a48a4318c10a3e8a631eb923a9a3c32 (patch)
tree8dcae921092fd9f9bc2ddf3b77af4a3a07b5eba1 /src/yuzu_cmd/CMakeLists.txt
parentcore: memory: Ensure thread safe access when pages are rasterizer cached (#5206) (diff)
parentcmake: Always enable Vulkan (diff)
downloadyuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar.gz
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar.bz2
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar.lz
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar.xz
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.tar.zst
yuzu-453560fb3a48a4318c10a3e8a631eb923a9a3c32.zip
Diffstat (limited to '')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index 57f9916f6..0b3f2cb54 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -4,26 +4,17 @@ add_executable(yuzu-cmd
config.cpp
config.h
default_ini.h
- emu_window/emu_window_sdl2_gl.cpp
- emu_window/emu_window_sdl2_gl.h
emu_window/emu_window_sdl2.cpp
emu_window/emu_window_sdl2.h
emu_window/emu_window_sdl2_gl.cpp
emu_window/emu_window_sdl2_gl.h
+ emu_window/emu_window_sdl2_vk.cpp
+ emu_window/emu_window_sdl2_vk.h
resource.h
yuzu.cpp
yuzu.rc
)
-if (ENABLE_VULKAN)
- target_sources(yuzu-cmd PRIVATE
- emu_window/emu_window_sdl2_vk.cpp
- emu_window/emu_window_sdl2_vk.h)
-
- target_include_directories(yuzu-cmd PRIVATE ../../externals/Vulkan-Headers/include)
- target_compile_definitions(yuzu-cmd PRIVATE HAS_VULKAN)
-endif()
-
create_target_directory_groups(yuzu-cmd)
target_link_libraries(yuzu-cmd PRIVATE common core input_common)
@@ -33,6 +24,8 @@ if (MSVC)
endif()
target_link_libraries(yuzu-cmd PRIVATE ${PLATFORM_LIBRARIES} SDL2 Threads::Threads)
+target_include_directories(yuzu-cmd PRIVATE ../../externals/Vulkan-Headers/include)
+
if(UNIX AND NOT APPLE)
install(TARGETS yuzu-cmd RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
endif()