summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-12-05 17:40:14 +0100
committerLioncash <mathew1800@gmail.com>2020-12-05 22:02:23 +0100
commitf95602f15207851b849c57e2a2dd313a087b2493 (patch)
treeed6122ab0a30de177acb2a59dffc8109232870ec /src/video_core/CMakeLists.txt
parentMerge pull request #5133 from lioncash/video-shadow2 (diff)
downloadyuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar.gz
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar.bz2
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar.lz
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar.xz
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.tar.zst
yuzu-f95602f15207851b849c57e2a2dd313a087b2493.zip
Diffstat (limited to '')
-rw-r--r--src/video_core/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index abcee2a1c..a021d61f5 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -297,13 +297,20 @@ if (ENABLE_NSIGHT_AFTERMATH)
endif()
if (MSVC)
- target_compile_options(video_core PRIVATE /we4267)
+ target_compile_options(video_core PRIVATE
+ /we4267 # 'var' : conversion from 'size_t' to 'type', possible loss of data
+ /we4456 # Declaration of 'identifier' hides previous local declaration
+ /we4457 # Declaration of 'identifier' hides function parameter
+ /we4458 # Declaration of 'identifier' hides class member
+ /we4459 # Declaration of 'identifier' hides global declaration
+ )
else()
target_compile_options(video_core PRIVATE
-Werror=conversion
-Wno-error=sign-conversion
-Werror=pessimizing-move
-Werror=redundant-move
+ -Werror=shadow
-Werror=switch
-Werror=type-limits
-Werror=unused-variable