summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2021-07-06 02:09:23 +0200
committerGitHub <noreply@github.com>2021-07-06 02:09:23 +0200
commitbf50345d4c13e34e69af0070632400b3472a1a11 (patch)
tree1af5586d2d416c1a347ea0bfabed30a3a56d51e0 /src/video_core/CMakeLists.txt
parentMerge pull request #6556 from Morph1984/default-mii (diff)
parentCMakeLists: Disable all warnings for external headers (diff)
downloadyuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar.gz
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar.bz2
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar.lz
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar.xz
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.tar.zst
yuzu-bf50345d4c13e34e69af0070632400b3472a1a11.zip
Diffstat (limited to '')
-rw-r--r--src/video_core/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index e31eb30c0..e4de55f4d 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -292,13 +292,12 @@ endif()
if (MSVC)
target_compile_options(video_core PRIVATE
- /we4267 # 'var' : conversion from 'size_t' to 'type', possible loss of data
- /we4244 # 'var' : conversion from integer to 'type', possible loss of data
+ /we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
+ /we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
/we4456 # Declaration of 'identifier' hides previous local declaration
/we4457 # Declaration of 'identifier' hides function parameter
/we4458 # Declaration of 'identifier' hides class member
/we4459 # Declaration of 'identifier' hides global declaration
- /we4715 # 'function' : not all control paths return a value
)
else()
target_compile_options(video_core PRIVATE