summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2022-10-24 02:25:18 +0200
committerGitHub <noreply@github.com>2022-10-24 02:25:18 +0200
commit0313ee77936a696f9135a31ac0b644e6ffe49ae8 (patch)
treeb9e4a934447468338c60add33375409341f5bc7d /src/input_common/CMakeLists.txt
parentMerge pull request #9095 from FernandoS27/meat-good-vegetable-bad (diff)
parentCMakeLists: Disable -Wbraced-scalar-init on Clang (diff)
downloadyuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.gz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.bz2
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.lz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.xz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.zst
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.zip
Diffstat (limited to '')
-rw-r--r--src/input_common/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index 2cf9eb97f..cc6f0ffc0 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -39,21 +39,14 @@ add_library(input_common STATIC
if (MSVC)
target_compile_options(input_common PRIVATE
/W4
- /WX
/we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
- /we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
- /we4245 # 'conversion': conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
+ /we4800 # Implicit conversion from 'type' to bool. Possible information loss
)
else()
target_compile_options(input_common PRIVATE
- -Werror
-Werror=conversion
- -Werror=ignored-qualifiers
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
- -Werror=unused-variable
)
endif()