summaryrefslogtreecommitdiffstats
path: root/src/dedicated_room/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2022-08-16 20:49:33 +0200
committerGitHub <noreply@github.com>2022-08-16 20:49:33 +0200
commit6f931d49c74017fb66bf285dd060bc455ae05c85 (patch)
tree8d0d47e28d1f35a2a97664a14dccb94e9a96fbb5 /src/dedicated_room/CMakeLists.txt
parentMerge pull request #8104 from Docteh/them_icons (diff)
parentcore/socket_proxy: Final nits (diff)
downloadyuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar.gz
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar.bz2
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar.lz
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar.xz
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.tar.zst
yuzu-6f931d49c74017fb66bf285dd060bc455ae05c85.zip
Diffstat (limited to '')
-rw-r--r--src/dedicated_room/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/dedicated_room/CMakeLists.txt b/src/dedicated_room/CMakeLists.txt
new file mode 100644
index 000000000..b674b915b
--- /dev/null
+++ b/src/dedicated_room/CMakeLists.txt
@@ -0,0 +1,27 @@
+# SPDX-FileCopyrightText: 2017 Citra Emulator Project
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMakeModules)
+
+add_executable(yuzu-room
+ yuzu_room.cpp
+ yuzu_room.rc
+)
+
+create_target_directory_groups(yuzu-room)
+
+target_link_libraries(yuzu-room PRIVATE common core network)
+if (ENABLE_WEB_SERVICE)
+ target_compile_definitions(yuzu-room PRIVATE -DENABLE_WEB_SERVICE)
+ target_link_libraries(yuzu-room PRIVATE web_service)
+endif()
+
+target_link_libraries(yuzu-room PRIVATE mbedtls)
+if (MSVC)
+ target_link_libraries(yuzu-room PRIVATE getopt)
+endif()
+target_link_libraries(yuzu-room PRIVATE ${PLATFORM_LIBRARIES} Threads::Threads)
+
+if(UNIX AND NOT APPLE)
+ install(TARGETS yuzu-room RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+endif()