summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2019-11-12 09:01:29 +0100
committerLioncash <mathew1800@gmail.com>2019-11-12 13:06:25 +0100
commit96d677bef04c1a3c7a06d475686302287115351c (patch)
treee3dd330897d55a29d26674cb1fb19ebe43c24bac /src/core/CMakeLists.txt
parentMerge pull request #3085 from bunnei/web-token-b64 (diff)
downloadyuzu-96d677bef04c1a3c7a06d475686302287115351c.tar
yuzu-96d677bef04c1a3c7a06d475686302287115351c.tar.gz
yuzu-96d677bef04c1a3c7a06d475686302287115351c.tar.bz2
yuzu-96d677bef04c1a3c7a06d475686302287115351c.tar.lz
yuzu-96d677bef04c1a3c7a06d475686302287115351c.tar.xz
yuzu-96d677bef04c1a3c7a06d475686302287115351c.tar.zst
yuzu-96d677bef04c1a3c7a06d475686302287115351c.zip
Diffstat (limited to '')
-rw-r--r--src/core/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 4f6a87b0a..f2e774a6b 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -522,6 +522,23 @@ add_library(core STATIC
tools/freezer.h
)
+if (MSVC)
+ target_compile_options(core PRIVATE
+ # 'expression' : signed/unsigned mismatch
+ /we4018
+ # 'argument' : conversion from 'type1' to 'type2', possible loss of data (floating-point)
+ /we4244
+ # 'conversion' : conversion from 'type1' to 'type2', signed/unsigned mismatch
+ /we4245
+ # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
+ /we4254
+ # 'var' : conversion from 'size_t' to 'type', possible loss of data
+ /we4267
+ # 'context' : truncation from 'type1' to 'type2'
+ /we4305
+ )
+endif()
+
create_target_directory_groups(core)
target_link_libraries(core PUBLIC common PRIVATE audio_core video_core)