summaryrefslogtreecommitdiffstats
path: root/src/core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2022-10-24 02:25:18 +0200
committerGitHub <noreply@github.com>2022-10-24 02:25:18 +0200
commit0313ee77936a696f9135a31ac0b644e6ffe49ae8 (patch)
treeb9e4a934447468338c60add33375409341f5bc7d /src/core/CMakeLists.txt
parentMerge pull request #9095 from FernandoS27/meat-good-vegetable-bad (diff)
parentCMakeLists: Disable -Wbraced-scalar-init on Clang (diff)
downloadyuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.gz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.bz2
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.lz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.xz
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.tar.zst
yuzu-0313ee77936a696f9135a31ac0b644e6ffe49ae8.zip
Diffstat (limited to '')
-rw-r--r--src/core/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
index 055bea641..113e663b5 100644
--- a/src/core/CMakeLists.txt
+++ b/src/core/CMakeLists.txt
@@ -774,19 +774,15 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
/we4245 # 'conversion': conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
+ /we4800 # Implicit conversion from 'type' to bool. Possible information loss
)
else()
target_compile_options(core PRIVATE
-Werror=conversion
- -Werror=ignored-qualifiers
- $<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
+ -Wno-sign-conversion
$<$<CXX_COMPILER_ID:Clang>:-fsized-deallocation>
-
- -Wno-sign-conversion
)
endif()