summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-09-06 15:12:58 +0200
committerGitHub <noreply@github.com>2023-09-06 15:12:58 +0200
commit5e424d791bd98c18a81a36405a419237abcc8116 (patch)
treedd83795955a607612d27f324bdb1bfab63de2c38 /src/common/CMakeLists.txt
parentMerge pull request #11437 from liamwhite/dump-shenanigans (diff)
parentmsvc: set warning level to /W4 globally (diff)
downloadyuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.gz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.bz2
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.lz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.xz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.zst
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.zip
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index bf97d9ba2..6d2badf76 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -191,8 +191,6 @@ if (MSVC)
_SILENCE_CXX17_CODECVT_HEADER_DEPRECATION_WARNING
)
target_compile_options(common PRIVATE
- /W4
-
/we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
/we4800 # Implicit conversion from 'type' to bool. Possible information loss