summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorCaptV0rt3x <c.vamsi.krishna.96@gmail.com>2018-08-29 13:33:55 +0200
committerCaptV0rt3x <c.vamsi.krishna.96@gmail.com>2018-09-07 08:24:51 +0200
commite3af341d5b077436d2d40d94ade8bc457bc05eb8 (patch)
treed9024890c3176e80188d09ee6aafcea40d59eb20 /src/common/CMakeLists.txt
parentMerge pull request #1250 from lioncash/file-sys (diff)
downloadyuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar.gz
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar.bz2
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar.lz
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar.xz
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.tar.zst
yuzu-e3af341d5b077436d2d40d94ade8bc457bc05eb8.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt24
1 files changed, 19 insertions, 5 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index d9424ea91..f41946cc6 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -1,13 +1,16 @@
# Generate cpp with Git revision from template
-# Also if this is a CI build, add the build name (ie: Nightly, Bleeding Edge) to the scm_rev file as well
+# Also if this is a CI build, add the build name (ie: Nightly, Canary) to the scm_rev file as well
set(REPO_NAME "")
+set(BUILD_VERSION "0")
if ($ENV{CI})
if ($ENV{TRAVIS})
set(BUILD_REPOSITORY $ENV{TRAVIS_REPO_SLUG})
+ set(BUILD_TAG $ENV{TRAVIS_TAG})
elseif($ENV{APPVEYOR})
set(BUILD_REPOSITORY $ENV{APPVEYOR_REPO_NAME})
+ set(BUILD_TAG $ENV{APPVEYOR_REPO_TAG_NAME})
endif()
- # regex capture the string nightly or bleeding-edge into CMAKE_MATCH_1
+ # regex capture the string nightly or canary into CMAKE_MATCH_1
string(REGEX MATCH "yuzu-emu/yuzu-?(.*)" OUTVAR ${BUILD_REPOSITORY})
if (${CMAKE_MATCH_COUNT} GREATER 0)
# capitalize the first letter of each word in the repo name.
@@ -16,10 +19,21 @@ if ($ENV{CI})
string(SUBSTRING ${WORD} 0 1 FIRST_LETTER)
string(SUBSTRING ${WORD} 1 -1 REMAINDER)
string(TOUPPER ${FIRST_LETTER} FIRST_LETTER)
- # this leaves a trailing space on the last word, but we actually want that
- # because of how it's styled in the title bar.
- set(REPO_NAME "${REPO_NAME}${FIRST_LETTER}${REMAINDER} ")
+ set(REPO_NAME "${REPO_NAME}${FIRST_LETTER}${REMAINDER}")
endforeach()
+ if (BUILD_TAG)
+ string(REGEX MATCH "${CMAKE_MATCH_1}-([0-9]+)" OUTVAR ${BUILD_TAG})
+ if (${CMAKE_MATCH_COUNT} GREATER 0)
+ set(BUILD_VERSION ${CMAKE_MATCH_1})
+ endif()
+ if (BUILD_VERSION)
+ # This leaves a trailing space on the last word, but we actually want that
+ # because of how it's styled in the title bar.
+ set(BUILD_FULLNAME "${REPO_NAME} #${BUILD_VERSION} ")
+ else()
+ set(BUILD_FULLNAME "")
+ endif()
+ endif()
endif()
endif()
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.cpp.in" "${CMAKE_CURRENT_SOURCE_DIR}/scm_rev.cpp" @ONLY)