summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-10-30 20:02:02 +0100
committerLioncash <mathew1800@gmail.com>2020-11-02 21:50:58 +0100
commit4a4b685a0420b0ac7c026cd2370c23d54f469976 (patch)
tree8de9e9a72563a369dac5ec8183e417e40ee4b8bf /src/common/CMakeLists.txt
parentCMakeLists: Resolve MSVC build failures (diff)
downloadyuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar.gz
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar.bz2
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar.lz
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar.xz
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.tar.zst
yuzu-4a4b685a0420b0ac7c026cd2370c23d54f469976.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index e50ab2922..207c7a0a6 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -190,6 +190,22 @@ if(ARCHITECTURE_x86_64)
)
endif()
+if (MSVC)
+ target_compile_definitions(common PRIVATE
+ # The standard library doesn't provide any replacement for codecvt yet
+ # so we can disable this deprecation warning for the time being.
+ _SILENCE_CXX17_CODECVT_HEADER_DEPRECATION_WARNING
+ )
+ target_compile_options(common PRIVATE
+ /W4
+ /WX
+ )
+else()
+ target_compile_options(common PRIVATE
+ -Werror
+ )
+endif()
+
create_target_directory_groups(common)
find_package(Boost 1.71 COMPONENTS context headers REQUIRED)