summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2023-07-18 21:36:20 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2023-07-21 16:56:55 +0200
commit267f3c7905972ad78713cd92f96e3073ea1c8996 (patch)
tree13fcd6568c57dbbc8d7417101fa54f332da7671f /src/common/CMakeLists.txt
parentshared_translation: Update memory layout mode strings (diff)
downloadyuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar.gz
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar.bz2
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar.lz
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar.xz
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.tar.zst
yuzu-267f3c7905972ad78713cd92f96e3073ea1c8996.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index e205055e6..bf97d9ba2 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -205,6 +205,7 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
-Werror=unreachable-code-aggressive
)
target_compile_definitions(common PRIVATE
+ # Clang 14 and earlier have errors when explicitly instantiating Settings::Setting
$<$<VERSION_LESS:$<CXX_COMPILER_VERSION>,15>:CANNOT_EXPLICITLY_INSTANTIATE>
)
endif()