summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2023-03-02 01:27:10 +0100
committerMorph <39850852+Morph1984@users.noreply.github.com>2023-03-05 07:41:28 +0100
commit1ed49f92dd56289e6e31a967e602c65ccedd4ff1 (patch)
treea151df116022445b7606614e31e9b3a3b8225152 /src/common/CMakeLists.txt
parentcommon: Implement a high resolution steady clock (diff)
downloadyuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar.gz
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar.bz2
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar.lz
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar.xz
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.tar.zst
yuzu-1ed49f92dd56289e6e31a967e602c65ccedd4ff1.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 9f5d4c265..58ff5f2f3 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -144,6 +144,14 @@ add_library(common STATIC
zstd_compression.h
)
+if (WIN32)
+ target_sources(common PRIVATE
+ windows/timer_resolution.cpp
+ windows/timer_resolution.h
+ )
+ target_link_libraries(common PRIVATE ntdll)
+endif()
+
if(ARCHITECTURE_x86_64)
target_sources(common
PRIVATE