summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-10-21 08:34:06 +0200
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-10-22 21:02:04 +0200
commite6ab1f673b88b1af6bd966886249c7824ec5dbd4 (patch)
tree045b57ae71c4b8efe34be8504d86638f13cf61ac /src/CMakeLists.txt
parentCMakeLists: Remove all redundant warnings (diff)
downloadyuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar.gz
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar.bz2
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar.lz
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar.xz
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.tar.zst
yuzu-e6ab1f673b88b1af6bd966886249c7824ec5dbd4.zip
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 71853eaad..cfd80886c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -76,6 +76,7 @@ if (MSVC)
/we4549 # 'operator1': operator before comma has no effect; did you intend 'operator2'?
/we4555 # Expression has no effect; expected expression with side-effect
/we4715 # 'function': not all control paths return a value
+ /we4826 # Conversion from 'type1' to 'type2' is sign-extended. This may cause unexpected runtime behavior.
/we4834 # Discarding return value of function with 'nodiscard' attribute
/we5038 # data member 'member1' will be initialized after data member 'member2'
/we5245 # 'function': unreferenced function with internal linkage has been removed