summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2019-04-15 23:32:47 +0200
committerLioncash <mathew1800@gmail.com>2019-04-17 03:23:34 +0200
commit819c21d99e39dd90cefd84a2c4d8884982456d44 (patch)
tree81850ba85c4465654727608948aa561b4a24dfd9 /src/CMakeLists.txt
parentMerge pull request #2378 from lioncash/ro (diff)
downloadyuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar.gz
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar.bz2
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar.lz
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar.xz
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.tar.zst
yuzu-819c21d99e39dd90cefd84a2c4d8884982456d44.zip
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 6c99dd5e2..9aea4af87 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -18,6 +18,9 @@ if (MSVC)
# Avoid windows.h from including some usually unused libs like winsocks.h, since this might cause some redefinition errors.
add_definitions(-DWIN32_LEAN_AND_MEAN)
+ # Ensure that projects build with Unicode support.
+ add_definitions(-DUNICODE -D_UNICODE)
+
# /W3 - Level 3 warnings
# /MP - Multi-threaded compilation
# /Zi - Output debugging information