summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2019-05-07 20:02:29 +0200
committerLioncash <mathew1800@gmail.com>2019-05-07 20:05:48 +0200
commit6ca7241bd955555e3421e5720cd7359380c83156 (patch)
tree09a513fb92bf3b5b3b735fe4e6c5090423d32fc7 /src/CMakeLists.txt
parentloader/nso: Remove left-in debug pragma (diff)
downloadyuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar.gz
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar.bz2
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar.lz
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar.xz
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.tar.zst
yuzu-6ca7241bd955555e3421e5720cd7359380c83156.zip
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt28
1 files changed, 19 insertions, 9 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9aea4af87..095aadbe8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,15 +21,25 @@ if (MSVC)
# Ensure that projects build with Unicode support.
add_definitions(-DUNICODE -D_UNICODE)
- # /W3 - Level 3 warnings
- # /MP - Multi-threaded compilation
- # /Zi - Output debugging information
- # /Zo - enhanced debug info for optimized builds
- # /permissive- - enables stricter C++ standards conformance checks
- # /EHsc - C++-only exception handling semantics
- # /Zc:throwingNew - let codegen assume `operator new` will never return null
- # /Zc:inline - let codegen omit inline functions in object files
- add_compile_options(/W3 /MP /Zi /Zo /permissive- /EHsc /std:c++latest /Zc:throwingNew,inline)
+ # /W3 - Level 3 warnings
+ # /MP - Multi-threaded compilation
+ # /Zi - Output debugging information
+ # /Zo - Enhanced debug info for optimized builds
+ # /permissive- - Enables stricter C++ standards conformance checks
+ # /EHsc - C++-only exception handling semantics
+ # /Zc:inline - Let codegen omit inline functions in object files
+ # /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
+ add_compile_options(
+ /W3
+ /MP
+ /Zi
+ /Zo
+ /permissive-
+ /EHsc
+ /std:c++latest
+ /Zc:inline
+ /Zc:throwingNew
+ )
# /GS- - No stack buffer overflow checks
add_compile_options("$<$<CONFIG:Release>:/GS->")