summaryrefslogtreecommitdiffstats
path: root/externals/gamemode/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-11-29 18:33:09 +0100
committerGitHub <noreply@github.com>2023-11-29 18:33:09 +0100
commit337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143 (patch)
tree70d10b1f7919e6ed6709acab3259c69b038add6c /externals/gamemode/CMakeLists.txt
parentMerge pull request #11902 from ameerj/ssbo-align (diff)
parentcmake: move gamemode target include into its file (diff)
downloadyuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar.gz
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar.bz2
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar.lz
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar.xz
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.tar.zst
yuzu-337e37f91dcc7d5b6a0a5da3f3196aa0f8df4143.zip
Diffstat (limited to '')
-rw-r--r--externals/gamemode/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/externals/gamemode/CMakeLists.txt b/externals/gamemode/CMakeLists.txt
new file mode 100644
index 000000000..87095642e
--- /dev/null
+++ b/externals/gamemode/CMakeLists.txt
@@ -0,0 +1,11 @@
+# SPDX-FileCopyrightText: Copyright 2023 yuzu Emulator Project
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+project(gamemode LANGUAGES CXX C)
+
+add_library(gamemode include/gamemode_client.h)
+
+target_link_libraries(gamemode PRIVATE common)
+
+target_include_directories(gamemode PUBLIC include)
+set_target_properties(gamemode PROPERTIES LINKER_LANGUAGE C)