summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2017-09-09 19:24:13 +0200
committerJames Rowe <jroweboy@gmail.com>2017-09-11 17:10:17 +0200
commit9e847b754933f09bdf19be0dc45fc32a65052965 (patch)
treefb904cde766d925d20fe78c41fb6a24eb742195c /externals/CMakeLists.txt
parentMerge pull request #2865 from wwylele/gs++ (diff)
downloadyuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar.gz
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar.bz2
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar.lz
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar.xz
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.tar.zst
yuzu-9e847b754933f09bdf19be0dc45fc32a65052965.zip
Diffstat (limited to '')
-rw-r--r--externals/CMakeLists.txt19
1 files changed, 17 insertions, 2 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 8e4bcf21f..4a4ba1101 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -1,5 +1,8 @@
# Definitions for all external bundled libraries
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMakeModules)
+include(DownloadExternals)
+
# Catch
add_library(catch-single-include INTERFACE)
target_include_directories(catch-single-include INTERFACE catch/single_include)
@@ -54,9 +57,21 @@ add_subdirectory(enet)
target_include_directories(enet INTERFACE ./enet/include)
if (ENABLE_WEB_SERVICE)
+ # msys installed curl is configured to use openssl, but that isn't portable
+ # since it relies on having the bundled certs install in the home folder for SSL
+ # by default on mingw, download the precompiled curl thats linked against windows native ssl
+ if (MINGW AND CITRA_USE_BUNDLED_CURL)
+ download_bundled_external("curl/" "curl-7_55_1" CURL_PREFIX)
+ set(CURL_PREFIX "${CMAKE_BINARY_DIR}/externals/curl-7_55_1")
+ set(CURL_FOUND YES)
+ set(CURL_INCLUDE_DIR "${CURL_PREFIX}/include" CACHE PATH "Path to curl headers")
+ set(CURL_LIBRARY "${CURL_PREFIX}/lib/libcurldll.a" CACHE PATH "Path to curl library")
+ set(CURL_DLL_DIR "${CURL_PREFIX}/lib/" CACHE PATH "Path to curl.dll")
+ set(USE_SYSTEM_CURL ON CACHE BOOL "")
+ endif()
# CPR
- option(BUILD_TESTING OFF)
- option(BUILD_CPR_TESTS OFF)
+ set(BUILD_TESTING OFF CACHE BOOL "")
+ set(BUILD_CPR_TESTS OFF CACHE BOOL "")
add_subdirectory(cpr)
target_include_directories(cpr INTERFACE ./cpr/include)