summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorarchshift <admin@archshift.com>2014-04-29 04:40:39 +0200
committerarchshift <admin@archshift.com>2014-04-29 04:40:39 +0200
commit5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041 (patch)
treefb68ecea60a4b06ab7142bedc22eb67913a63449 /CMakeLists.txt
parentFix complaints about functions that could not be found (diff)
downloadyuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.gz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.bz2
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.lz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.xz
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.tar.zst
yuzu-5a9c2ce5ea1b272d73001acaf9ec15f1c0e5e041.zip
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a588fe193..bd21af25e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,8 @@ cmake_minimum_required(VERSION 2.6)
project(citra)
-SET(GCC_COMPILE_FLAGS "-std=c++11 -fpermissive")
+SET(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -fpermissive")
+SET(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -fpermissive")
# silence some spam
add_definitions(-Wno-attributes)
@@ -11,11 +12,16 @@ add_definitions(${GCC_COMPILE_FLAGS})
# dependency checking
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/CMakeTests)
-include(FindOpenGL REQUIRED)
include(FindX11 REQUIRED)
find_package(PkgConfig REQUIRED)
+find_package(GLEW REQUIRED)
+find_package(OpenGL REQUIRED)
pkg_search_module(GLFW REQUIRED glfw3)
+IF (APPLE)
+ FIND_LIBRARY(COREFOUNDATION_LIBRARY CoreFoundation)
+ENDIF (APPLE)
+
include_directories(${GLFW_INCLUDE_DIRS})
option(DISABLE_QT4 "Disable Qt4 GUI" OFF)
if(NOT DISABLE_QT4)
@@ -40,6 +46,7 @@ git_branch_name(GIT_BRANCH)
# external includes
include_directories(${OPENGL_INCLUDE_DIR})
+include_directories(${GLEW_INCLUDE_DIR})
# internal includes
include_directories(src)