summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/zipp/py310compat.py
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/zipp/py310compat.py
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/zipp/py310compat.py')
-rw-r--r--venv/lib/python3.9/site-packages/zipp/py310compat.py12
1 files changed, 12 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/zipp/py310compat.py b/venv/lib/python3.9/site-packages/zipp/py310compat.py
new file mode 100644
index 00000000..8244124c
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/zipp/py310compat.py
@@ -0,0 +1,12 @@
+import sys
+import io
+
+
+te_impl = 'lambda encoding, stacklevel=2, /: encoding'
+te_impl_37 = te_impl.replace(', /', '')
+_text_encoding = eval(te_impl) if sys.version_info > (3, 8) else eval(te_impl_37)
+
+
+text_encoding = (
+ io.text_encoding if sys.version_info > (3, 10) else _text_encoding # type: ignore
+)