summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/LICENSE30
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/METADATA113
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/RECORD27
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/WHEEL5
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/top_level.txt1
-rw-r--r--venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/zip-safe1
7 files changed, 178 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/LICENSE b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/LICENSE
new file mode 100644
index 00000000..710010f1
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/LICENSE
@@ -0,0 +1,30 @@
+Copyright (C) 2010, 2011 Sebastian Thiel and contributors
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+* Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright
+notice, this list of conditions and the following disclaimer in the
+documentation and/or other materials provided with the distribution.
+
+* Neither the name of the async project nor the names of
+its contributors may be used to endorse or promote products derived
+from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/METADATA b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/METADATA
new file mode 100644
index 00000000..ee33c524
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/METADATA
@@ -0,0 +1,113 @@
+Metadata-Version: 2.1
+Name: smmap
+Version: 5.0.0
+Summary: A pure Python implementation of a sliding window memory map manager
+Home-page: https://github.com/gitpython-developers/smmap
+Author: Sebastian Thiel
+Author-email: byronimo@gmail.com
+License: BSD
+Platform: any
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Environment :: Console
+Classifier: Intended Audience :: Developers
+Classifier: License :: OSI Approved :: BSD License
+Classifier: Operating System :: OS Independent
+Classifier: Operating System :: POSIX
+Classifier: Operating System :: Microsoft :: Windows
+Classifier: Operating System :: MacOS :: MacOS X
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 3
+Classifier: Programming Language :: Python :: 3.6
+Classifier: Programming Language :: Python :: 3.7
+Classifier: Programming Language :: Python :: 3.8
+Classifier: Programming Language :: Python :: 3.9
+Classifier: Programming Language :: Python :: 3.10
+Classifier: Programming Language :: Python :: 3 :: Only
+Requires-Python: >=3.6
+Description-Content-Type: text/markdown
+
+## Motivation
+
+When reading from many possibly large files in a fashion similar to random access, it is usually the fastest and most efficient to use memory maps.
+
+Although memory maps have many advantages, they represent a very limited system resource as every map uses one file descriptor, whose amount is limited per process. On 32 bit systems, the amount of memory you can have mapped at a time is naturally limited to theoretical 4GB of memory, which may not be enough for some applications.
+
+
+## Limitations
+
+* **System resources (file-handles) are likely to be leaked!** This is due to the library authors reliance on a deterministic `__del__()` destructor.
+* The memory access is read-only by design.
+
+
+## Overview
+
+![Python package](https://github.com/gitpython-developers/smmap/workflows/Python%20package/badge.svg)
+
+Smmap wraps an interface around mmap and tracks the mapped files as well as the amount of clients who use it. If the system runs out of resources, or if a memory limit is reached, it will automatically unload unused maps to allow continued operation.
+
+To allow processing large files even on 32 bit systems, it allows only portions of the file to be mapped. Once the user reads beyond the mapped region, smmap will automatically map the next required region, unloading unused regions using a LRU algorithm.
+
+Although the library can be used most efficiently with its native interface, a Buffer implementation is provided to hide these details behind a simple string-like interface.
+
+For performance critical 64 bit applications, a simplified version of memory mapping is provided which always maps the whole file, but still provides the benefit of unloading unused mappings on demand.
+
+
+
+## Prerequisites
+
+* Python 3.6+
+* OSX, Windows or Linux
+
+The package was tested on all of the previously mentioned configurations.
+
+## Installing smmap
+
+[![Documentation Status](https://readthedocs.org/projects/smmap/badge/?version=latest)](https://readthedocs.org/projects/smmap/?badge=latest)
+
+Its easiest to install smmap using the [pip](http://www.pip-installer.org/en/latest) program:
+
+```bash
+$ pip install smmap
+```
+
+As the command will install smmap in your respective python distribution, you will most likely need root permissions to authorize the required changes.
+
+If you have downloaded the source archive, the package can be installed by running the `setup.py` script:
+
+```bash
+$ python setup.py install
+```
+
+It is advised to have a look at the **Usage Guide** for a brief introduction on the different database implementations.
+
+
+
+## Homepage and Links
+
+The project is home on github at https://github.com/gitpython-developers/smmap .
+
+The latest source can be cloned from github as well:
+
+* git://github.com/gitpython-developers/smmap.git
+
+
+For support, please use the git-python mailing list:
+
+* http://groups.google.com/group/git-python
+
+
+Issues can be filed on github:
+
+* https://github.com/gitpython-developers/smmap/issues
+
+A link to the pypi page related to this repository:
+
+* https://pypi.org/project/smmap/
+
+
+## License Information
+
+*smmap* is licensed under the New BSD License.
+
+
+
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/RECORD b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/RECORD
new file mode 100644
index 00000000..eb9aa569
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/RECORD
@@ -0,0 +1,27 @@
+smmap-5.0.0.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+smmap-5.0.0.dist-info/LICENSE,sha256=iOnZP3CNEQsyioNDAt0dXGr72lMOdyHRXYCzUR2G8jU,1519
+smmap-5.0.0.dist-info/METADATA,sha256=Fk4ARflM-i58flLvrjIPhsFUEnC8Soaml51ObDXX380,4225
+smmap-5.0.0.dist-info/RECORD,,
+smmap-5.0.0.dist-info/WHEEL,sha256=U88EhGIw8Sj2_phqajeu_EAi3RAo8-C6zV3REsWbWbs,92
+smmap-5.0.0.dist-info/top_level.txt,sha256=h0Tp1UdaROCy2bjWNha1MFpwgVghxEUQsaLHbZs96Gw,6
+smmap-5.0.0.dist-info/zip-safe,sha256=AbpHGcgLb-kRsJGnwFEktk7uzpZOCcBY74-YBdrKVGs,1
+smmap/__init__.py,sha256=PcnjXprv7SB7WONeQ0qk93xgfBPi-by7_j0stBChsrU,342
+smmap/__pycache__/__init__.cpython-39.pyc,,
+smmap/__pycache__/buf.cpython-39.pyc,,
+smmap/__pycache__/mman.cpython-39.pyc,,
+smmap/__pycache__/util.cpython-39.pyc,,
+smmap/buf.py,sha256=CzvLJ93vVKqNTt09XXMvagMb9PBE0qOYaJA83e86T_g,5765
+smmap/mman.py,sha256=q2VUnBzTw46OndAenaU-vgjoNlR1d3itWktxu-dpAUQ,24021
+smmap/test/__init__.py,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
+smmap/test/__pycache__/__init__.cpython-39.pyc,,
+smmap/test/__pycache__/lib.cpython-39.pyc,,
+smmap/test/__pycache__/test_buf.cpython-39.pyc,,
+smmap/test/__pycache__/test_mman.cpython-39.pyc,,
+smmap/test/__pycache__/test_tutorial.cpython-39.pyc,,
+smmap/test/__pycache__/test_util.cpython-39.pyc,,
+smmap/test/lib.py,sha256=fsegoTch5fFXXd5MmJuL3pkrtM4gFQ5w2v2SpQaxmhg,1460
+smmap/test/test_buf.py,sha256=YN3fNuORHrV2kzv9EIZ0UBnljuy0f-ZgUk1KQZoYRe8,5439
+smmap/test/test_mman.py,sha256=hOvjf3yuCqplOkToUNoSpGy20qzxCLq6ebf_46xM9LU,10818
+smmap/test/test_tutorial.py,sha256=ZwCphCbKAGYt_fn_CiOJ9lWwpWwpqE4-zBUp-v-t9eM,3174
+smmap/test/test_util.py,sha256=3hJyW9Km7k7XSgxxtDOkG8eVagk3lIzP4H2pR0S2ewg,3468
+smmap/util.py,sha256=x40DONHh3VljRqCvSsrUHATt6UC1gbIWzsNkAlDfy6c,7486
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/WHEEL b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/WHEEL
new file mode 100644
index 00000000..e499438d
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/WHEEL
@@ -0,0 +1,5 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.33.1)
+Root-Is-Purelib: true
+Tag: py3-none-any
+
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/top_level.txt b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/top_level.txt
new file mode 100644
index 00000000..2765cefa
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/top_level.txt
@@ -0,0 +1 @@
+smmap
diff --git a/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/zip-safe b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/zip-safe
new file mode 100644
index 00000000..8b137891
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/smmap-5.0.0.dist-info/zip-safe
@@ -0,0 +1 @@
+