summaryrefslogtreecommitdiffstats
path: root/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info
diff options
context:
space:
mode:
authornoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
committernoptuno <repollo.marrero@gmail.com>2023-04-28 02:29:30 +0200
commit355dee533bb34a571b9367820a63cccb668cf866 (patch)
tree838af886b4fec07320aeb10f0d1e74ba79e79b5c /venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info
parentadded pyproject.toml file (diff)
downloadgpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.gz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.bz2
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.lz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.xz
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.tar.zst
gpt4free-355dee533bb34a571b9367820a63cccb668cf866.zip
Diffstat (limited to 'venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info')
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/INSTALLER1
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/LICENSE.txt21
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/METADATA68
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/RECORD11
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/REQUESTED0
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/WHEEL6
-rw-r--r--venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/top_level.txt1
7 files changed, 108 insertions, 0 deletions
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/INSTALLER b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/INSTALLER
new file mode 100644
index 00000000..a1b589e3
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/INSTALLER
@@ -0,0 +1 @@
+pip
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/LICENSE.txt b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/LICENSE.txt
new file mode 100644
index 00000000..404eb21a
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/LICENSE.txt
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Mykal Burris
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/METADATA b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/METADATA
new file mode 100644
index 00000000..2d19df20
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/METADATA
@@ -0,0 +1,68 @@
+Metadata-Version: 2.1
+Name: TwoCaptcha
+Version: 0.0.1
+Summary: 2Captcha Python3 API Wrapper
+Home-page: https://github.com/My-kal/2Captcha
+Author: Mykal Burris
+License: MIT
+Keywords: 2captcha development
+Classifier: Development Status :: 3 - Alpha
+Classifier: Intended Audience :: Developers
+Classifier: Topic :: Software Development :: Libraries :: Python Modules
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Programming Language :: Python :: 3.5
+License-File: LICENSE.txt
+Requires-Dist: requests
+
+TwoCaptcha
+==========
+
+2Captcha Python3 API Wrapper
+
+Prerequisites
+-------------
+
+You will need a ``2Captcha API Key`` which can be found `here`_ after
+registering for 2Captcha on https://2captcha.com
+
+Usage
+-----
+
+TwoCaptcha
+~~~~~~~~~~
+
+.. code:: py
+
+ from twocaptcha import TwoCaptcha
+
+ API_KEY = 'YOUR_API_KEY_HERE'
+ twoCaptcha = TwoCaptcha(API_KEY)
+
+TwoCaptcha.solve\_captcha
+~~~~~~~~~~~~~~~~~~~~~~~~~
+
+.. code:: py
+
+ page_url = 'http://www.example.com'
+ site_key = '6Le4AQgUAAAAAABhHEq7RWQNJwGR_M-6Jni9tgtA'
+ captcha_token = twoCaptcha.solve_captcha(site_key=site_key, page_url=page_url)
+ print(captcha_token) # Ex. '03AE...'
+
+TwoCaptcha.get\_balance
+~~~~~~~~~~~~~~~~~~~
+
+.. code:: py
+
+ balance = twoCaptcha.get_balance()
+ print(balance) # Ex. '6.11472'
+
+TODO:
+-----
+
+- [ ] proxy support
+- [ ] poll interval
+- [ ] request error handling
+- [ ] request unblocking
+- [ ] unit tests
+
+.. _here: https://2captcha.com/setting
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/RECORD b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/RECORD
new file mode 100644
index 00000000..cc3fe84f
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/RECORD
@@ -0,0 +1,11 @@
+TwoCaptcha-0.0.1.dist-info/INSTALLER,sha256=zuuue4knoyJ-UwPPXg8fezS7VCrXJQrAP7zeNuwvFQg,4
+TwoCaptcha-0.0.1.dist-info/LICENSE.txt,sha256=EGPUjp1_D5lnxuKQmanSqGAFDME1qGoq_xBr4-MWnpo,1069
+TwoCaptcha-0.0.1.dist-info/METADATA,sha256=UvaiwZx1EukQIoI0jbCCDF_Qkk1GPBzhQfuvPyWlXGU,1472
+TwoCaptcha-0.0.1.dist-info/RECORD,,
+TwoCaptcha-0.0.1.dist-info/REQUESTED,sha256=47DEQpj8HBSa-_TImW-5JCeuQeRkm5NMpJWZG3hSuFU,0
+TwoCaptcha-0.0.1.dist-info/WHEEL,sha256=a-zpFRIJzOq5QfuhBzbhiA1eHTzNCJn8OdRvhdNX0Rk,110
+TwoCaptcha-0.0.1.dist-info/top_level.txt,sha256=AvFZdM89oM6Vo97ZTxT9AxHWpwoO3_Qf5ORMV3NClFE,11
+twocaptcha/__init__.py,sha256=zAlluY7p2MD2I3BkEwxK9N_1btu6HHl-8mKvL27uGqc,41
+twocaptcha/__pycache__/__init__.cpython-39.pyc,,
+twocaptcha/__pycache__/wrapper.cpython-39.pyc,,
+twocaptcha/wrapper.py,sha256=ufejickD_iYDhYwgv2k2fD-IPo8L330TGV8PMipygmE,1833
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/REQUESTED b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/REQUESTED
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/REQUESTED
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/WHEEL b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/WHEEL
new file mode 100644
index 00000000..f771c29b
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/WHEEL
@@ -0,0 +1,6 @@
+Wheel-Version: 1.0
+Generator: bdist_wheel (0.40.0)
+Root-Is-Purelib: true
+Tag: py2-none-any
+Tag: py3-none-any
+
diff --git a/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/top_level.txt b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/top_level.txt
new file mode 100644
index 00000000..c6021f31
--- /dev/null
+++ b/venv/lib/python3.9/site-packages/TwoCaptcha-0.0.1.dist-info/top_level.txt
@@ -0,0 +1 @@
+twocaptcha