summaryrefslogtreecommitdiffstats
path: root/g4f/.v1/pyproject.toml
diff options
context:
space:
mode:
authort.me/xtekky <98614666+xtekky@users.noreply.github.com>2023-06-24 03:47:00 +0200
committert.me/xtekky <98614666+xtekky@users.noreply.github.com>2023-06-24 03:47:00 +0200
commit5db58fd87f230fbe5bae599bb4b120ab42cad3be (patch)
tree770be13bca77c5d04dfe3265f378431df788706f /g4f/.v1/pyproject.toml
parentMerge pull request #664 from LopeKinz/main (diff)
downloadgpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar.gz
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar.bz2
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar.lz
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar.xz
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.tar.zst
gpt4free-5db58fd87f230fbe5bae599bb4b120ab42cad3be.zip
Diffstat (limited to 'g4f/.v1/pyproject.toml')
-rw-r--r--g4f/.v1/pyproject.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/g4f/.v1/pyproject.toml b/g4f/.v1/pyproject.toml
new file mode 100644
index 00000000..7281f679
--- /dev/null
+++ b/g4f/.v1/pyproject.toml
@@ -0,0 +1,37 @@
+[tool.poetry]
+name = "gpt4free"
+version = "0.1.0"
+description = ""
+authors = []
+license = "GPL-3.0"
+readme = "README.md"
+packages = [{ include = "gpt4free" }]
+exclude = ["**/*.txt"]
+
+[tool.poetry.dependencies]
+python = "^3.10"
+
+colorama = "^0.4.6"
+curl-cffi = "^0.5.5"
+fake-useragent = "^1.1.3"
+Levenshtein = "*"
+mailgw_temporary_email = "*"
+names = "^0.3.0"
+pycryptodome = "*"
+pydantic = "^1.10.7"
+pypasser = "^0.0.5"
+pymailtm = "*"
+random-password-generator = "*"
+requests = "^2.29.0"
+retrying = "*"
+selenium = "^4.9.0"
+streamlit-chat = { git = "https://github.com/AI-Yash/st-chat", rev = "ffb0583" }
+streamlit = "^1.21.0"
+tls-client = "^0.2"
+twocaptcha = "^0.0.1"
+websocket-client = "^1.5.1"
+
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"