summaryrefslogtreecommitdiffstats
path: root/src/PolarSSL++/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/PolarSSL++/CMakeLists.txt')
-rw-r--r--src/PolarSSL++/CMakeLists.txt41
1 files changed, 0 insertions, 41 deletions
diff --git a/src/PolarSSL++/CMakeLists.txt b/src/PolarSSL++/CMakeLists.txt
deleted file mode 100644
index 3d77e15d1..000000000
--- a/src/PolarSSL++/CMakeLists.txt
+++ /dev/null
@@ -1,41 +0,0 @@
-project (Cuberite)
-
-include_directories ("${PROJECT_SOURCE_DIR}/../")
-
-set(SRCS
- AesCfb128Decryptor.cpp
- AesCfb128Encryptor.cpp
- BlockingSslClientSocket.cpp
- BufferedSslContext.cpp
- CallbackSslContext.cpp
- CtrDrbgContext.cpp
- CryptoKey.cpp
- EntropyContext.cpp
- RsaPrivateKey.cpp
- Sha1Checksum.cpp
- SslContext.cpp
- X509Cert.cpp
-)
-
-set(HDRS
- AesCfb128Decryptor.h
- AesCfb128Encryptor.h
- BlockingSslClientSocket.h
- BufferedSslContext.h
- CallbackSslContext.h
- CtrDrbgContext.h
- CryptoKey.h
- EntropyContext.h
- RsaPrivateKey.h
- SslContext.h
- Sha1Checksum.h
- X509Cert.h
-)
-
-if(NOT MSVC)
- add_library(PolarSSL++ ${SRCS} ${HDRS})
-
- if (UNIX)
- target_link_libraries(PolarSSL++ mbedtls)
- endif()
-endif()