summaryrefslogtreecommitdiffstats
path: root/src/Mobs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Mobs/CMakeLists.txt')
-rw-r--r--src/Mobs/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/src/Mobs/CMakeLists.txt b/src/Mobs/CMakeLists.txt
index 2c092c15f..e0a55a17b 100644
--- a/src/Mobs/CMakeLists.txt
+++ b/src/Mobs/CMakeLists.txt
@@ -5,7 +5,6 @@ project (MCServer)
include_directories ("${PROJECT_SOURCE_DIR}/../")
SET (SRCS
- AggressiveMonster.cpp
Bat.cpp
Blaze.cpp
CaveSpider.cpp
@@ -21,8 +20,6 @@ SET (SRCS
MagmaCube.cpp
Monster.cpp
Mooshroom.cpp
- PassiveAggressiveMonster.cpp
- PassiveMonster.cpp
Pig.cpp
Sheep.cpp
Skeleton.cpp
@@ -38,7 +35,6 @@ SET (SRCS
ZombiePigman.cpp)
SET (HDRS
- AggressiveMonster.h
Bat.h
Blaze.h
CaveSpider.h
@@ -56,8 +52,6 @@ SET (HDRS
Monster.h
Mooshroom.h
Ocelot.h
- PassiveAggressiveMonster.h
- PassiveMonster.h
Pig.h
Sheep.h
Silverfish.h
@@ -75,4 +69,5 @@ SET (HDRS
if(NOT MSVC)
add_library(Mobs ${SRCS} ${HDRS})
+ target_link_libraries(Mobs Components)
endif()