summaryrefslogtreecommitdiffstats
path: root/lib/lua/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/lua/CMakeLists.txt')
-rw-r--r--lib/lua/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/lib/lua/CMakeLists.txt b/lib/lua/CMakeLists.txt
index 63ac18e90..af03f4b1a 100644
--- a/lib/lua/CMakeLists.txt
+++ b/lib/lua/CMakeLists.txt
@@ -25,6 +25,11 @@ else()
add_library(lua ${SOURCE})
endif()
+# Tell Lua what dynamic loader to use (for LuaRocks):
if (UNIX)
- target_link_libraries(lua m dl)
+ add_definitions(-DLUA_USE_DLOPEN)
+endif()
+
+if (UNIX)
+ target_link_libraries(lua m ${DYNAMIC_LOADER})
endif()