summaryrefslogtreecommitdiffstats
path: root/tests/PieceRotation/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2017-02-26 23:03:24 +0100
committerMattes D <github@xoft.cz>2017-05-04 09:49:30 +0200
commit96fdd72d45221c03d9369c1edcddc83f27656fd4 (patch)
treefe96bbeaab2465924d4c613299c8002ba0b224e5 /tests/PieceRotation/CMakeLists.txt
parentGen: Moved PiecePool into a separate file. (diff)
downloadcuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar.gz
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar.bz2
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar.lz
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar.xz
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.tar.zst
cuberite-96fdd72d45221c03d9369c1edcddc83f27656fd4.zip
Diffstat (limited to 'tests/PieceRotation/CMakeLists.txt')
-rw-r--r--tests/PieceRotation/CMakeLists.txt102
1 files changed, 0 insertions, 102 deletions
diff --git a/tests/PieceRotation/CMakeLists.txt b/tests/PieceRotation/CMakeLists.txt
deleted file mode 100644
index bb1b37a53..000000000
--- a/tests/PieceRotation/CMakeLists.txt
+++ /dev/null
@@ -1,102 +0,0 @@
-enable_testing()
-
-include_directories(${CMAKE_SOURCE_DIR}/src/)
-include_directories(SYSTEM ${CMAKE_SOURCE_DIR}/lib/)
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-
-add_definitions(-DTEST_GLOBALS=1)
-
-set (SHARED_SRCS
- ${CMAKE_SOURCE_DIR}/src/BiomeDef.cpp
- ${CMAKE_SOURCE_DIR}/src/BlockArea.cpp
- ${CMAKE_SOURCE_DIR}/src/Cuboid.cpp
- ${CMAKE_SOURCE_DIR}/src/ChunkData.cpp
- ${CMAKE_SOURCE_DIR}/src/StringCompression.cpp
- ${CMAKE_SOURCE_DIR}/src/StringUtils.cpp
-
- ${CMAKE_SOURCE_DIR}/src/Bindings/LuaState.cpp
-
- ${CMAKE_SOURCE_DIR}/src/Generating/ChunkDesc.cpp
- ${CMAKE_SOURCE_DIR}/src/Generating/PiecePool.cpp
- ${CMAKE_SOURCE_DIR}/src/Generating/Prefab.cpp
- ${CMAKE_SOURCE_DIR}/src/Generating/PrefabPiecePool.cpp
- ${CMAKE_SOURCE_DIR}/src/Generating/VerticalLimit.cpp
- ${CMAKE_SOURCE_DIR}/src/Generating/VerticalStrategy.cpp
-
- ${CMAKE_SOURCE_DIR}/src/Noise/Noise.cpp
-
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/Event.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/File.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/GZipFile.cpp
- ${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.cpp
-
- ${CMAKE_SOURCE_DIR}/src/WorldStorage/FastNBT.cpp
- ${CMAKE_SOURCE_DIR}/src/WorldStorage/SchematicFileSerializer.cpp
-)
-
-set (SHARED_HDRS
- ${CMAKE_SOURCE_DIR}/src/BiomeDef.h
- ${CMAKE_SOURCE_DIR}/src/BlockArea.h
- ${CMAKE_SOURCE_DIR}/src/Cuboid.h
- ${CMAKE_SOURCE_DIR}/src/ChunkData.h
- ${CMAKE_SOURCE_DIR}/src/Globals.h
- ${CMAKE_SOURCE_DIR}/src/StringCompression.h
- ${CMAKE_SOURCE_DIR}/src/StringUtils.h
-
- ${CMAKE_SOURCE_DIR}/src/Bindings/LuaState.h
-
- ${CMAKE_SOURCE_DIR}/src/Generating/ChunkDesc.h
- ${CMAKE_SOURCE_DIR}/src/Generating/PiecePool.h
- ${CMAKE_SOURCE_DIR}/src/Generating/Prefab.h
- ${CMAKE_SOURCE_DIR}/src/Generating/PrefabPiecePool.h
- ${CMAKE_SOURCE_DIR}/src/Generating/VerticalLimit.h
- ${CMAKE_SOURCE_DIR}/src/Generating/VerticalStrategy.h
-
- ${CMAKE_SOURCE_DIR}/src/Noise/Noise.h
-
- ${CMAKE_SOURCE_DIR}/src/OSSupport/CriticalSection.h
- ${CMAKE_SOURCE_DIR}/src/OSSupport/Event.h
- ${CMAKE_SOURCE_DIR}/src/OSSupport/File.h
- ${CMAKE_SOURCE_DIR}/src/OSSupport/GZipFile.h
- ${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.h
-
- ${CMAKE_SOURCE_DIR}/src/WorldStorage/FastNBT.h
- ${CMAKE_SOURCE_DIR}/src/WorldStorage/SchematicFileSerializer.h
-)
-
-set (SRCS
- PieceRotationTest.cpp
- Stubs.cpp
- LuaState_Typedefs.inc
- LuaState_Declaration.inc
- Bindings.h
-)
-
-
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- add_flags_cxx("-Wno-error=global-constructors")
- add_flags_cxx("-Wno-error=switch-enum")
-endif()
-
-
-if (MSVC)
- # Add the MSVC-specific LeakFinder sources:
- list (APPEND SHARED_SRCS ${CMAKE_SOURCE_DIR}/src/LeakFinder.cpp ${CMAKE_SOURCE_DIR}/src/StackWalker.cpp)
- list (APPEND SHARED_HDRS ${CMAKE_SOURCE_DIR}/src/LeakFinder.h ${CMAKE_SOURCE_DIR}/src/StackWalker.h)
-endif()
-
-source_group("Shared" FILES ${SHARED_SRCS} ${SHARED_HDRS})
-source_group("Sources" FILES ${SRCS})
-add_executable(PieceRotation ${SRCS} ${SHARED_SRCS} ${SHARED_HDRS})
-target_link_libraries(PieceRotation tolualib zlib)
-add_test(NAME PieceRotation-test WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} COMMAND PieceRotation)
-
-
-
-
-# Put the projects into solution folders (MSVC):
-set_target_properties(
- PieceRotation
- PROPERTIES FOLDER Tests
-)