summaryrefslogtreecommitdiffstats
path: root/src/Mobs/CMakeLists.txt
diff options
context:
space:
mode:
authorSafwat Halaby <SafwatHalaby@users.noreply.github.com>2015-12-13 06:33:59 +0100
committerSafwat Halaby <SafwatHalaby@users.noreply.github.com>2015-12-13 06:33:59 +0100
commit86b51083a174713eeaa4a9e602bb71acb51d55f5 (patch)
treec73d4b10ce1e4159a29b386e2d933ccaaa3c5d23 /src/Mobs/CMakeLists.txt
parentMerge pull request #2739 from Gargaj/patch-6 (diff)
parentDecoupled cMonster and path recalc logic, re-implemented recalc (diff)
downloadcuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar.gz
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar.bz2
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar.lz
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar.xz
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.tar.zst
cuberite-86b51083a174713eeaa4a9e602bb71acb51d55f5.zip
Diffstat (limited to '')
-rw-r--r--src/Mobs/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Mobs/CMakeLists.txt b/src/Mobs/CMakeLists.txt
index 5c374f9ee..14c7a8ca3 100644
--- a/src/Mobs/CMakeLists.txt
+++ b/src/Mobs/CMakeLists.txt
@@ -25,6 +25,7 @@ SET (SRCS
PassiveAggressiveMonster.cpp
PassiveMonster.cpp
Path.cpp
+ PathFinder.cpp
Pig.cpp
Rabbit.cpp
Sheep.cpp
@@ -39,7 +40,7 @@ SET (SRCS
Wolf.cpp
Zombie.cpp
ZombiePigman.cpp)
-
+
SET (HDRS
AggressiveMonster.h
Bat.h
@@ -64,6 +65,7 @@ SET (HDRS
PassiveAggressiveMonster.h
PassiveMonster.h
Path.h
+ PathFinder.h
Pig.h
Rabbit.h
Sheep.h