summaryrefslogtreecommitdiffstats
path: root/src/HTTPServer/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2016-01-03 15:59:55 +0100
committerMattes D <github@xoft.cz>2016-03-01 16:19:56 +0100
commitfea556ca1b8aeec975f5276d5d829ee6275841d9 (patch)
tree9a61a61edbb232c01bfb34e1c2959542d470887e /src/HTTPServer/CMakeLists.txt
parentAdded HTTPResponseParser. (diff)
downloadcuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar.gz
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar.bz2
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar.lz
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar.xz
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.tar.zst
cuberite-fea556ca1b8aeec975f5276d5d829ee6275841d9.zip
Diffstat (limited to 'src/HTTPServer/CMakeLists.txt')
-rw-r--r--src/HTTPServer/CMakeLists.txt45
1 files changed, 0 insertions, 45 deletions
diff --git a/src/HTTPServer/CMakeLists.txt b/src/HTTPServer/CMakeLists.txt
deleted file mode 100644
index 4597f6eda..000000000
--- a/src/HTTPServer/CMakeLists.txt
+++ /dev/null
@@ -1,45 +0,0 @@
-
-cmake_minimum_required (VERSION 2.6)
-project (Cuberite)
-
-include_directories ("${PROJECT_SOURCE_DIR}/../")
-
-SET (SRCS
- EnvelopeParser.cpp
- HTTPFormParser.cpp
- HTTPMessage.cpp
- HTTPRequestParser.cpp
- HTTPResponseParser.cpp
- HTTPServer.cpp
- HTTPServerConnection.cpp
- MultipartParser.cpp
- NameValueParser.cpp
- SslHTTPServerConnection.cpp
- TransferEncodingParser.cpp
- UrlParser.cpp
-)
-
-SET (HDRS
- EnvelopeParser.h
- HTTPFormParser.h
- HTTPMessage.h
- HTTPRequestParser.h
- HTTPResponseParser.h
- HTTPServer.h
- HTTPServerConnection.h
- MultipartParser.h
- NameValueParser.h
- SslHTTPServerConnection.h
- TransferEncodingParser.h
- UrlParser.h
-)
-
-if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set_source_files_properties(HTTPServer.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors ")
- set_source_files_properties(HTTPServerConnection.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum")
- set_source_files_properties(HTTPMessage.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=tautological-compare")
-endif()
-
-if(NOT MSVC)
- add_library(HTTPServer ${SRCS} ${HDRS})
-endif()