summaryrefslogtreecommitdiffstats
path: root/src/Entities/CMakeLists.txt
diff options
context:
space:
mode:
authorworktycho <work.tycho@gmail.com>2016-01-07 02:31:27 +0100
committerworktycho <work.tycho@gmail.com>2016-01-07 02:31:27 +0100
commit5593db13eb84b756d10a7e5054c74c88d78ff85b (patch)
tree58db7ffefac6b6878f9ebc37ff7d754f56cceabd /src/Entities/CMakeLists.txt
parentMerge pull request #2844 from mathias-github/silktouch (diff)
parentFixed Clang warnings. (diff)
downloadcuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar.gz
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar.bz2
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar.lz
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar.xz
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.tar.zst
cuberite-5593db13eb84b756d10a7e5054c74c88d78ff85b.zip
Diffstat (limited to '')
-rw-r--r--src/Entities/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Entities/CMakeLists.txt b/src/Entities/CMakeLists.txt
index 71964e90d..0416d5338 100644
--- a/src/Entities/CMakeLists.txt
+++ b/src/Entities/CMakeLists.txt
@@ -61,10 +61,7 @@ SET (HDRS
WitherSkullEntity.h)
if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
- set_source_files_properties(Entity.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion -Wno-error=global-constructors -Wno-error=switch-enum ")
- set_source_files_properties(EntityEffect.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=switch-enum ")
- set_source_files_properties(Floater.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion ")
- set_source_files_properties(Player.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=sign-conversion -Wno-error=switch-enum -Wno-error=conversion ")
+ set_source_files_properties(Entity.cpp PROPERTIES COMPILE_FLAGS "-Wno-error=global-constructors")
endif()
if(NOT MSVC)