summaryrefslogtreecommitdiffstats
path: root/lib/zlib/CMakeLists.txt
diff options
context:
space:
mode:
authorMattes D <github@xoft.cz>2014-02-16 15:56:50 +0100
committerMattes D <github@xoft.cz>2014-02-16 15:56:50 +0100
commit2a78ecf97efb925afd53071f0d887a69df000ade (patch)
treede1dbd50090f4835c5e80cd8bf0a33c9e7087782 /lib/zlib/CMakeLists.txt
parentMerge pull request #686 from Howaner/GlobalFixes (diff)
parentFixed comment (diff)
downloadcuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar.gz
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar.bz2
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar.lz
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar.xz
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.tar.zst
cuberite-2a78ecf97efb925afd53071f0d887a69df000ade.zip
Diffstat (limited to '')
-rw-r--r--lib/zlib/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/lib/zlib/CMakeLists.txt b/lib/zlib/CMakeLists.txt
index b1b74031d..6c52578ee 100644
--- a/lib/zlib/CMakeLists.txt
+++ b/lib/zlib/CMakeLists.txt
@@ -8,12 +8,14 @@ file(GLOB SOURCE
"*.c"
)
-add_library(zlib ${SOURCE})
+if(NOT TARGET zlib)
+ add_library(zlib ${SOURCE})
-if (MSVC)
- # Remove SCL warnings, we expect this library to have been tested safe
- SET_TARGET_PROPERTIES(
- zlib PROPERTIES COMPILE_FLAGS "-D_CRT_SECURE_NO_WARNINGS"
- )
+ if (MSVC)
+ # Remove SCL warnings, we expect this library to have been tested safe
+ SET_TARGET_PROPERTIES(
+ zlib PROPERTIES COMPILE_FLAGS "-D_CRT_SECURE_NO_WARNINGS"
+ )
+ endif()
endif()