summaryrefslogtreecommitdiffstats
path: root/lib/lua/CMakeLists.txt
diff options
context:
space:
mode:
authorHowaner <franzi.moos@googlemail.com>2014-02-28 15:29:50 +0100
committerHowaner <franzi.moos@googlemail.com>2014-02-28 15:29:50 +0100
commit27b98dec2b62a1fe88130c6a5c2c840dde293a5e (patch)
tree6c92a2e4f8614e74362d2695961a9ffba8d08965 /lib/lua/CMakeLists.txt
parentFix Double Slabs, fix Slab Meta and add more things to burnable (diff)
parentMerge pull request #709 from Howaner/GlobalFixes (diff)
downloadcuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar.gz
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar.bz2
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar.lz
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar.xz
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.tar.zst
cuberite-27b98dec2b62a1fe88130c6a5c2c840dde293a5e.zip
Diffstat (limited to 'lib/lua/CMakeLists.txt')
-rw-r--r--lib/lua/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/lua/CMakeLists.txt b/lib/lua/CMakeLists.txt
index 4babae9b2..db112d557 100644
--- a/lib/lua/CMakeLists.txt
+++ b/lib/lua/CMakeLists.txt
@@ -47,8 +47,12 @@ if (WIN32)
)
endif()
+ set_target_properties(lua PROPERTIES OUTPUT_NAME "lua51")
+
# NOTE: The DLL for each configuration is stored at the same place, thus overwriting each other.
- # This is known, however such behavior is needed for LuaRocks - they always load "lua.dll"
+ # This is known, however such behavior is needed for LuaRocks - they always load "lua5.1.dll" or "lua51.dll"
+ # We make it work by compiling to "lua51.dll" and providing a proxy-DLL "lua5.1.dll"
+ # See http://lua-users.org/wiki/LuaProxyDllFour for details
else()
add_library(lua ${SOURCE})
endif()